WordPress Özelleştir Çalışmıyor Hatası ve Çözümü

WordPress Görünüm -> Özelleştir dediğimde sayfada hiç bir alana tıklayamıyorum. Tarayıcı hata kaynağını açtığımda aşağıdaki hatalarla karşılaştım:

Uncaught TypeError: t.onChangeSectionExpanded is not a function
at customize-widgets.min.js?ver=54217cb151203a814dd21ea6d0b8763c:2
at Array.forEach (<anonymous>)
at Object.completeCallback (customize-widgets.min.js?ver=54217cb151203a814dd21ea6d0b8763c:2)
at Object.onChangeExpanded (load-scripts.php?c=1&load[chunk_0]=heartbeat,customize-base,customize-controls,customize-widgets,wp-viewport,mce-view,imgareaselect&ver=5.8:6)
at Object.onChangeExpanded (customize-widgets.min.js?ver=54217cb151203a814dd21ea6d0b8763c:2)
at Object._toggleExpanded (load-scripts.php?c=1&load[chunk_0]=heartbeat,customize-base,customize-controls,customize-widgets,wp-viewport,mce-view,imgareaselect&ver=5.8:6)
at Object.collapse (load-scripts.php?c=1&load[chunk_0]=heartbeat,customize-base,customize-controls,customize-widgets,wp-viewport,mce-view,imgareaselect&ver=5.8:6)
at load-scripts.php?c=1&load[chunk_0]=heartbeat,customize-base,customize-controls,customize-widgets,wp-viewport,mce-view,imgareaselect&ver=5.8:6
at Function.dr (load-scripts.php?c=1&load[chunk_0]=jquery-core,jquery-migrate,regenerator-runtime,wp-polyfill,wp-hooks,underscore,wp-dom-ready&ver=5.8:18)
at i.onChangeActive (load-scripts.php?c=1&load[chunk_0]=heartbeat,customize-base,customize-controls,customize-widgets,wp-viewport,mce-view,imgareaselect&ver=5.8:6)
customize-widgets.min.js?ver=54217cb151203a814dd21ea6d0b8763c:2 Uncaught TypeError: t.onChangeSectionExpanded is not a function
at customize-widgets.min.js?ver=54217cb151203a814dd21ea6d0b8763c:2
at Array.forEach (<anonymous>)
at Object.completeCallback (customize-widgets.min.js?ver=54217cb151203a814dd21ea6d0b8763c:2)
at Object.onChangeExpanded (load-scripts.php?c=1&load[chunk_0]=heartbeat,customize-base,customize-controls,customize-widgets,wp-viewport,mce-view,imgareaselect&ver=5.8:6)
at Object.onChangeExpanded (customize-widgets.min.js?ver=54217cb151203a814dd21ea6d0b8763c:2)
at Object._toggleExpanded (load-scripts.php?c=1&load[chunk_0]=heartbeat,customize-base,customize-controls,customize-widgets,wp-viewport,mce-view,imgareaselect&ver=5.8:6)
at Object.collapse (load-scripts.php?c=1&load[chunk_0]=heartbeat,customize-base,customize-controls,customize-widgets,wp-viewport,mce-view,imgareaselect&ver=5.8:6)
at Function.<anonymous> (load-scripts.php?c=1&load[chunk_0]=heartbeat,customize-base,customize-controls,customize-widgets,wp-viewport,mce-view,imgareaselect&ver=5.8:6)
at Object.<anonymous> (load-scripts.php?c=1&load[chunk_0]=heartbeat,customize-base,customize-controls,customize-widgets,wp-viewport,mce-view,imgareaselect&ver=5.8:4)
at Function.each (load-scripts.php?c=1&load[chunk_0]=jquery-core,jquery-migrate,regenerator-runtime,wp-polyfill,wp-hooks,underscore,wp-dom-ready&ver=5.8:2)

Araştırmalarımda wordpress’in yeni güncellemesiyle birlikte Bileşenler alanını da güncellediklerini fark ettim. Yeni gutenberg modelinde bloklu hale getirmişler fazla inceleme fırsatım olmadı.

Sorunun çözümü için nasıl gutenberg yazı editörünü devre dışı bırakmak için klasik editörü kuruyorsak, aynı şekilde bileşenler içinde classic widget eklentisini kurmamız gerekiyor. Yaşadığım bu hatayı bu şekilde çözümlemiş oldum.

WordPress sürümüm: 5.8

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Bu site reCAPTCHA ve Google tarafından korunmaktadır Gizlilik Politikası ve Kullanım Şartları uygula.